Puzzle Financial - Degraded performance – Incident details
Report an issue
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
Dark mode
All systems operational
Degraded performance
Resolved
Operational
Started 6 months ago
Lasted 34 minutes
Affected
puzzle.io
Partial outage from 6:47 PM to 7:21 PM
api.puzzle.io
Partial outage from 6:47 PM to 7:21 PM
Updates
Resolved
July 23, 2024 at 7:21 PM
Resolved
July 23, 2024 at 7:21 PM
Something got stale. Services restarted manually.
Investigating
July 23, 2024 at 6:47 PM
Investigating
July 23, 2024 at 6:47 PM
We are currently investigating this incident.